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TCPのイーサネット通信でエラーコード「RHAA067/068/069」の通信エラーが出たときの対処方法は?(PLCが三菱電機株式会社Qシリーズの場合)

下記のエラーが表示されているときの、原因対処方法は下記を参照して下さい。
[表示されているエラー]
・RHAA067:(PLC*):通信開始要求に応答がありません。
・RHAA068:(PLC*):読出し要求に応答がありません。
・RHAA069:(PLC*):書込み要求に応答がありません。
[この記事の対象となるPLCのリンクインターフェイスユニットの製品型式]
QJ71E71 / QJ71E71-B2 / QJ71E71-B5 / QJ71E71-100
※UDPのイーサネット通信の場合は、次のFAQを参照してください。
原因
上記のエラーメッセージが表示される原因には次の2つのことが考えられます。
※テキストをクリックしていただくとそれぞれの対処方法へリンクします。
1.表示器と接続機器に設定するIPアドレスやポート番号に誤りがある
2.ネットワークで異常が発生している
対処方法
1.表示器と接続機器に設定しているIPアドレスやポート番号の確認方法
表示器と接続機器に設定するIPアドレスやポート番号があっているかを以下に示す確認方法で確認してください。
※テキストをクリックしていただくとそれぞれの確認方法へリンクします。
①表示器側のIPアドレス、ポート番号の確認方法
(1)表示器側のIPアドレスは表示器本体でしか確認できません。
表示器をオフラインに切り替え、「本体設定」→「イーサネット設定」を選択し表示器のIPアドレスを確認します。
※ここでの「ポート」は接続機器との通信用ポートではなく、上位PCとイーサネットでやり取りするためのポート番号になりますので、初期値の8000のままにします。
(2)次に、接続機器との通信を行う際のポート番号及び接続機器側のIPアドレス、ポート番号を確認します。
表示器本体で確認をする場合、表示器をオフラインに切り替え、「周辺設定設定」→「接続機器設定」を選択します。
接続している通信ドライバが表示されますので選択し、表示器側のポート番号を確認します。
(3)上部「機器設定」を選択し、接続機器側のIPアドレス、ポート番号を確認します。
※作画ソフト(GP-ProEX)で確認を行う場合、GP-ProEXを起動し「システム設定ウインドウ」→「接続機器設定」を選択し、表示器側のポート番号及び接続機器側のIPアドレス、ポート番号を確認します。
通信設定
機器別設定
[基本設定]タブ
[他局アクセス]タブ
[ラダーモニタ]タブ
②接続機器側のIPアドレスの確認方法
表示器側に設定されていた接続機器のIPアドレス、ポート番号と差異が無いかどうか、接続機器のラダーソフトで確認します。
(1)ラダーソフト(GX-Developer)を起動し、「パラメータ」→「ネットワークパラメータ」を選択し、「ネットワークパラメータ選択」→「Ethernet/CC IE/MELSECNET」を選択します。「ネットワークパラメータ MNET/10H Ethernet 枚数設定 」を確認します。
(2)「動作設定」を選択し、「Ethernet 動作設定」を確認します。
(3)「オープン設定」を選択し設定を確認します。
2.ネットワーク環境が正常かどうかの確認方法
PINGコマンドを用いてネットワーク環境が正常がどうか確認します。
PCと表示器、接続機器をLANケーブルで直接繋ぎ、PC側のIPアドレスをネットワーク環境に合わせます。
windowsのスタートメニューから「すべてのプログラム」→「アクセサリ」→「コマンドプロンプト」を選択します。
まず「ipconfig」とコマンド入力しPC側のIPアドレスがネットワーク環境に合っているかどうかを確認し、次に「ping ***.***.***.***(表示器及び接続機器のIPアドレス)」とコマンド入力し、相手からの応答があるかどうか確認します。(正常に応答がある場合は「Reply from ***.***.***.***(IPアドレス)」と表示されます)

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